TIA Portal STEP7 打开项目报错

2018年7月21日20:38:47 发表评论 266 阅读

在TIA Portal step7打开已有项目的时候,有时会报错,通常有以下几种情况:

缺少所需HSP

缺少相关软件

软件版本不一致

缺少所需HSP

当TIA Portal step7尚未安装项目中已使用的硬件支持包时,会出现错误信息如图1,这时需要安装缺少的支持包。

缺少相关软件

当项目中还用了TIA Portal其他软件组态时,比如,SINAMICS Startdrive,WinCC Professional等,会出现如图2所示错误信息,这时应该把缺少的软件安装齐全。

软件版本不一致

TIA Portal STEP7 项目在高版本软件中打开时需要升级或以兼容模式打开。

TIA Portal STEP7 V14 打开早期版本项目

如果要在TIA Portal STEP7 V14中打开TIA Portal STEP7 V13 SP1版本的项目,必须升级项目版本,如图3所示,V14不再支持兼容模式打开早期版本。

图3.

如果无法升级项目,应该先在TIA Portal STEP7 V13 SP1中通过下面两个菜单命令对项目进行完整编译:

  • 编译>硬件 ( 完全重建 )
  • 编译>软件(重新编译所有块)

如果要在TIA Portal STEP7 V14中打开早于TIA Portal STEP7 V13 SP1版本的项目,必须先用TIA Portal STEP7 V13 SP1保存和编译。否则,会出现错误信息如图4所示。

TIA Portal STEP7 V13 SP1 打开早期版本项目

如果要在TIA Portal STEP7 V13 SP1中打开TIA Portal STEP7 V13 或 V12版本的项目,可以选择升级项目或兼容模式打开。

当需要使用新版本功能时,必须升级项目。

图5.

如图5所示,当选择“是”时,则升级项目。

如图5所示,当选择“否”时,则以兼容模式打开。

如果要在TIA Portal STEP7 V13 SP1中打开TIA Portal STEP7 V11版本的项目,必须升级项目。

TIA Portal STEP7 V13 打开早期版本项目

如果要在TIA Portal STEP7 V13中打开TIA Portal STEP7 V12版本的项目,可以选择升级项目或兼容模式打开。

如果要在TIA Portal STEP7 V13中打开TIA Portal STEP7 V11版本的项目,必须升级项目。

TIA Portal STEP7 V12 打开早期版本项目

如果要在TIA Portal STEP7 V12中打开TIA Portal STEP7 V11版本的项目,可以选择升级项目或兼容模式打开。

weinxin
plc入门知识问答
所有PLC工程师都会关注的微信公众账号,只需输入您的问题,就会有答案

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: