如何检查在编辑一个STEP7项目时所需要的软件包?

2018年10月25日21:41:44 发表评论 406 阅读

说明:
如果所编辑的项目含有使用一个软件包创建的对象,那么需要该软件包来编辑该项目。当打开项目时,系统将自动检查所需要的软件包。然后,将列出系统中未找到的软件包。

首先,在弹出的消息框中提示某类型的一个或多个对象无法显示,以及无法加载S7 ...服务器。点击OK确认该消息。然后会得到缺少的软件包的列表(例如, S7-HiGraph - 图  01)。

在 SIMATIC 管理器中用光标选中项目名,通过菜单 Edit > Object Properties 选择项目属性对话框。在对话框中选择打开“Required software packages”标签项。在此可以得到这个 STEP 7 项目使用的所有软件包以及这些软件包是否已经在 PC 上安装的列表。

如果,例如,希望将自己创建的项目转发给别人(例如同事/商业伙伴),由于对方安装的 STEP7 上的软件可能不如您的完整,为了使您的项目更好的适应对方计算机上的STEP7 软件,在这种情况下让对方知道需要哪些软件包来编辑项目是很有用的。

为此,在 SIMATIC 管理器中选中项目,选择菜单命令“Edit > Object Properties> Tab: Required software packages”。在此,可以看到编辑该项目所需的软件包总览。

在下面的情况下所需软件包的信息是完整的:

  • 如果使用STEP 7 V5.2或更高版本创建了项目(或者多重项目中的所有项目)或库;
  • 如果打开 S7 项目时已经使用菜单命令“Edit > Object Properties>  Required software packages” 自动检查了项目需要的软件包。
weinxin
plc入门知识问答
所有PLC工程师都会关注的微信公众账号,只需输入您的问题,就会有答案

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: